[m-rev.] Re: your mail

Julien Fischer juliensf at students.cs.mu.OZ.AU
Mon Oct 13 15:43:58 AEST 2003


On Mon, 13 Oct 2003, Fergus Henderson wrote:

> On 13-Oct-2003, Julien Fischer <juliensf at students.cs.mu.OZ.AU> wrote:
> >
> > Add a little more functionality to the OpenGL binding.  In particular,
> > add bindings for vertex fragment operations and (some) support for
> > selection.  Make some trivial changes to the binding for mogl.get_error/3.
>
> The rationale for adding functionality is obvious,
> but what's the rationale for those trivial changes?
(See below).

> ...
> > Index: mogl.m
> > @@ -443,13 +442,12 @@
> >  		;	equal
> >  		;	gequal
> >  		;	greater
> > -		;	notequal
> > -		.
> > +		;	not_equal.
>
> That change isn't mentioned in the log message, is it?
> It would be helpful to mention it and to give some rationale.
>
Done.

> > @@ -487,19 +483,18 @@
> ...
> > -:- type logical_operation
> > +:- type logical_op
>
> Likewise.
>
Done.

> >  		--->	clear
> >  		;	(and)
> >  		;	and_reverse
> >  		;	copy
> >  		;	and_inverted
> > -		;	noop
> > +		;	no_op
>
> Likewise.
>
Done.

> > @@ -736,10 +727,9 @@
> >  		GL_STACK_UNDERFLOW,
> >  		GL_OUT_OF_MEMORY
> >  	};
> > -	GLenum	err;
> > -	Integer i;
> > -
> > -	Err = 0;
> > +
> > +	GLenum	err = 0;
> > +	int i;
Ah, I should have actually added an MR_ prefix to Integer there,
rather than change it to an int.

> >
> >  	err = glGetError();
>
> There's no point setting err = 0 when you assign err = glGetError()
> immediately afterwards.
>
I've removed the initializer.

Amended log message follows:

Estimated hours taken: 3
Branches: main

Add a little more functionality to the OpenGL binding.  In particular,
add bindings for vertex fragment operations and (some) support for
selection.
Rename the logical_operation type so that the name is more consistent
with that of other types. e.g. stencil_op, accum_op.
Change the name of the constructors `notequal' and `noop' to `not_equal'
and `no_op' respectively.  The new names are clearer than the old ones.
Add a missing MR_ prefix and remove an unnecessary assignment in the
binding for mogl.get_error/3.

extras/graphics/mercury_opengl/mogl.m:
	Add bindings for vertex fragment operations and selection.
	Add a missing MR_ prefix and remove an unnecessary assignment
	in the binding of glGetError().
	Rename logical_operation type as logical_op for consistency with
	stencil_op and accum_op.
	s/notequal/not_equal s/noop/no_op/.
extras/graphics/mercury_opengl/mglu.m:
	Add a binding for gluOrtho2D().

--------------------------------------------------------------------------
mercury-reviews mailing list
post:  mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe:   Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------



More information about the reviews mailing list