[m-dev.] proposal: rename the modules of the first termination analyzer
Zoltan Somogyi
zoltan.somogyi at runbox.com
Sun Aug 30 15:57:20 AEST 2026
On Sun, 30 Aug 2026 15:44:32 +1000, Julien Fischer <jfischer at opturion.com> wrote:
> > Actually, this raises a new question. All the termination-related modules are
> > currently part of the transform_hlds package.
>
> transform_or_analyse_hlds would be more accurate, but that's a bit long.
>
> > Should the packages be
> > transform_hlds.term_{osi,constr}, or just term_{osi,constr}? I vote
> > for the latter.
>
> The latter involves adding two separate packages, one for each analyser?
> I would be inclined to move both of them into a termination package.
What advantage do you think that arrangement has over making both
term_{osi,constr} top level packages? I don't see any. I also don't like
the way deep package hierarchies lead to file names such as
transform_hlds.ctgc.structure_reuse.direct_detect_garbage.c,
and would prefer to avoid contributing to that.
Zoltan,
More information about the developers
mailing list