[m-dev.] proposal: rename the modules of the first termination analyzer
Julien Fischer
jfischer at opturion.com
Sun Aug 30 15:44:32 AEST 2026
On Sat, 29 Aug 2026 at 22:20, Zoltan Somogyi <zoltan.somogyi at runbox.com> wrote:
>
>
> On Sat, 29 Aug 2026 14:01:06 +0200 (CEST), "Zoltan Somogyi" <zoltan.somogyi at runbox.com> wrote:
>
> > > (Incidentally, both analysers could probably be restructured to use submodules.)
> >
> > Agreed.
>
> Actually, this raises a new question. All the termination-related modules are
> currently part of the transform_hlds package.
transform_or_analyse_hlds would be more accurate, but that's a bit long.
> Should the packages be
> transform_hlds.term_{osi,constr}, or just term_{osi,constr}? I vote
> for the latter.
The latter involves adding two separate packages, one for each analyser?
I would be inclined to move both of them into a termination package.
Julien.
More information about the developers
mailing list