[m-dev.] for discussion: reading multibyte integers from binary streams
jfischer at opturion.com
Wed Jan 2 23:04:30 AEDT 2019
On Wed, 2 Jan 2019, Zoltan Somogyi wrote:
> On Wed, 2 Jan 2019 11:40:14 +0000 (UTC), Julien Fischer <jfischer at opturion.com> wrote:
>>> I would go with something like "multibyte_int_read_result" or "possibly_incomplete_read_result".
>> Those seem unwieldly. I think the name should be fairly generic since
>> we are very likely to end up with a similar type in stream.m as well.
> "maybe_short_read_result"? "item_read_result"?
You seem very keen to have "read" in there ;-) Almost all of the other
result types are used with read type operations and none of them contain
the word read.
How about maybe_incomplete_result?
More information about the developers