[m-dev.] oops! ROTD-2006-03-29 not compiling on powerpc.apple.darwin8.5

doug.auclair at logicaltypes.com doug.auclair at logicaltypes.com
Fri Mar 31 02:47:41 AEDT 2006

Dear all,

The ROTD-2006-03-29 compiler distribution does not compile on
powerpc.apple.darwin8.5.  The ROTD-2006-03-28 compiler distribution
compiled and installed on the same platform without a hitch.

Do you have a copy of a pre-compiled binary distribution for that
platform that I could have?  I understand ROTD-2006-03-29 solves
some mode-checking issues that reduced compile time and space
down from O(N^2) to O(NlogN).  I need this as the previous release
SEGFAULTs when it tries to compile my program.

The error dump follows.  Normally, when this kind of error (rarely)
happens, a 'mmake clean; make' solves the problem.  I tried this
approach but it didn't work: I got the same error again.

Any help would be much appreciated.

Doug Auclair

-------------- next part --------------
../scripts/mgnuc --grade hlc.gc        --       -fPIC -DMR_PIC \
        -c version_store.c -o version_store.pic_o
../scripts/mgnuc --grade hlc.gc        --       -fPIC -DMR_PIC \
        -c version_types.c -o version_types.pic_o
../scripts/ml --make-shared-lib --grade hlc.gc      --no-mercury-stdlib-dir -L../boehm_gc -L../mps_gc/code -L../runtime -L../library -L../trace -L../mdbcomp -L../browser -R/Users/dauclair/languages/mercury/mercury-2006-03-29-rotd-powerpc.apple.darwin8.5/lib/mercury/lib/hlc.gc -R/Users/dauclair/languages/mercury/mercury-2006-03-29-rotd-powerpc.apple.darwin8.5/lib/mercury/lib  --trace-init-file ../browser/mer_browser.init --trace-init-file ../mdbcomp/mer_mdbcomp.init        --    -install_name /Users/dauclair/languages/mercury/mercury-2006-03-29-rotd-powerpc.apple.darwin8.5/lib/mercury/lib/hlc.gc/libmer_std.dylib -o libmer_std.dylib \
        array.pic_o array2d.pic_o assoc_list.pic_o bag.pic_o benchmarking.pic_o bimap.pic_o bintree.pic_o bintree_set.pic_o bitmap.pic_o bool.pic_o bt_array.pic_o builtin.pic_o char.pic_o construct.pic_o cord.pic_o counter.pic_o deconstruct.pic_o dir.pic_o enum.pic_o eqvclass.pic_o exception.pic_o float.pic_o gc.pic_o getopt.pic_o getopt_io.pic_o graph.pic_o group.pic_o hash_table.pic_o injection.pic_o int.pic_o integer.pic_o io.pic_o lexer.pic_o library.pic_o list.pic_o map.pic_o math.pic_o maybe.pic_o mer_std.pic_o multi_map.pic_o mutvar.pic_o ops.pic_o pair.pic_o parser.pic_o pprint.pic_o pqueue.pic_o private_builtin.pic_o profiling_builtin.pic_o prolog.pic_o queue.pic_o random.pic_o rational.pic_o rbtree.pic_o relation.pic_o require.pic_o robdd.pic_o rtti_implementation.pic_o set.pic_o set_bbbtree.pic_o set_ctree234.pic_o set_ordlist.pic_o set_tree234.pic_o set_unordlist.pic_o solutions.pic_o sparse_bitset.pic_o stack.pic_o std_util.pic_o store.pic_o string.pic_o svarray.pic_o svbag.pic_o svbimap.pic_o sveqvclass.pic_o svmap.pic_o svmulti_map.pic_o svqueue.pic_o svrelation.pic_o svset.pic_o svvarset.pic_o table_builtin.pic_o term.pic_o term_io.pic_o term_size_prof_builtin.pic_o term_to_xml.pic_o time.pic_o tree234.pic_o type_desc.pic_o unit.pic_o univ.pic_o varset.pic_o version_array.pic_o version_array2d.pic_o version_bitmap.pic_o version_hash_table.pic_o version_store.pic_o version_types.pic_o \
            -lmer_rt -lgc    
ld: warning -L: directory name (../mps_gc/code) does not exist
ld: Undefined symbols:
<type_ctor_info for type 'univ.univ'/0>
/usr/bin/libtool: internal link edit command failed
make[2]: *** [libmer_std.dylib] Error 1
make[1]: *** [library] Error 2
make: *** [all] Error 2

More information about the developers mailing list