[m-dev.] For review: introduce field names to code_info

Zoltan Somogyi zs at cs.mu.OZ.AU
Wed Feb 9 15:40:49 AEDT 2000


> -		set(prog_var),	% Variables that are forward live
> +		live_vars :: set(prog_var),
> +				% Variables that are forward live
>  				% after this goal.

I think forward_live_vars would be better.

> -		set(lval),	% The set of temporary locations currently in
> +		temporaries :: set(lval),
> +				% The set of temporary locations currently in
>  				% use. These lvals must be all be keys in the
>  				% map of temporary locations ever used, which
>  				% is one of the persistent fields below. Any
>  				% keys in that map which are not in this set
>  				% are free for reuse.

The name temps_in_use would be better; the variable names that refer to
this field are like that.

>  		% PERSISTENT fields
> - 		int,		% Counter for the local labels used
> + 		label_count :: int,
> +				% Counter for the local labels used
>  				% by this procedure.

Label_count is ambiguous. It should be either last_label_num or next_label_num,
depending on which is the case.

> +		cell_count :: int,
> +				% Counter for cells in this proc.

Likewise.

Otherwise, the change is great.

Zoltan.
--------------------------------------------------------------------------
mercury-developers mailing list
Post messages to:       mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions:          mercury-developers-request at cs.mu.oz.au
--------------------------------------------------------------------------



More information about the developers mailing list