[m-dev.] For review: introduce field names to code_info

David Overton dmo at hydra.cs.mu.oz.au
Wed Feb 9 15:48:19 AEDT 2000

On Wed, 09 Feb, 2000 at 02:05:50PM EST, Thomas Conway wrote:
> If you don't like any of the field names, suggest better ones!

> +
> +code_info__get_varset(CI^prog_vars, CI, CI).
> +
> +code_info__get_var_slot_count(CI^num_var_stackslots, CI, CI).
> +

I have another suggestion:  keep the field names the same as the
access predicates (e.g. `varset' and `var_slot_count' for the above
two fields).  This will make it easier for people looking at the type
definition to work out which access predicate they need for a
particular field.

David Overton       Department of Computer Science & Software Engineering
PhD Student         The University of Melbourne, Australia
+61 3 9344 9159     http://www.cs.mu.oz.au/~dmo
mercury-developers mailing list
Post messages to:       mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions:          mercury-developers-request at cs.mu.oz.au

More information about the developers mailing list