[m-dev.] for review: new method of handling failures, part 7 of 6 :-(
Zoltan Somogyi
zs at cs.mu.OZ.AU
Fri Jul 3 15:03:48 AEST 1998
> > +** This test allows Mercury developers who have not done a cvs update
> > +** of the changes introducing the new failure handling method in the
> > +** code generator to retain the ability to do bootchecks, by adding
> > +** -DMR_DISABLE_REDOFR to EXTRA_CFLAGS in their Mmake.stage.params,
> > +** and using bootcheck -r.
> > +**
> > +** The test should be deleted once there are no such developers.
> > +*/
> > +
> > +#ifdef MR_DISABLE_REDOFR
> > +#undef MR_USE_REDOFR
> > +#endif
>
> s/#undef/ #undef/
>
> I don't quite understand this code --
> where will MR_USE_REDOFR get #defined in the first place,
> thus requiring that we #undef it here?
As I said in my previous message, eventually it will defined in mercury_imp.h
a couple of lines above the quoted stuff.
> > + } else if (streq(words[0], "toggle_echo")) {
> > + MR_supply_newline = !MR_supply_newline;
>
> Does toggle_echo actually cause the commands to be
> echoed, or just it just result in the printing of
> a newline? If the latter, then the command name should
> be changed. If the former, then this code looks wrong.
The variable was misnamed; it is now MR_echo_commands.
> Apparently you haven't done a `cvs add' for cut_test.m
> and cut_test.exp? At any rate, they didn't appear in the diff.
This is what Tyson's makediff script does.
I have compiled with your other suggestions on this review fragment.
Zoltan.
More information about the developers
mailing list