[m-dev.] for review: subdivision of mercury_trace.c

Fergus Henderson fjh at cs.mu.OZ.AU
Fri Apr 10 02:25:21 AEST 1998

On 09-Apr-1998, Erwan Jahier <Erwan.Jahier at irisa.fr> wrote:
> Fergus Henderson wrote:
> > 
> > Something else that could usefully go with this change is to rename
> > MR_trace_display_user() as MR_trace_event_internal()
> > and MR_trace_debugger_step() as MR_trace_event_external().
> MR_query_handler() would be a nice (for MR_trace_debugger_step) name as
> it sticks to the naming used in the referenced Mireille article jlp98

I think internal consistency within the Mercury runtime
is slightly more important -- and much easier to achieve --
than consistency with names used elsewhere.

So, thanks for the suggestion, but no thanks ;-)

If you want to add a comment explaining the correspondence
with `query_handler' in Mereille's article, feel free.

Fergus Henderson <fjh at cs.mu.oz.au>  |  "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh>  |  of excellence is a lethal habit"
PGP: finger fjh at        |     -- the last words of T. S. Garp.

More information about the developers mailing list