[m-dev.] for review: subdivision of mercury_trace.c

Erwan Jahier Erwan.Jahier at irisa.fr
Fri Apr 10 02:01:53 AEST 1998

Fergus Henderson wrote:

> Something else that could usefully go with this change is to rename
> MR_trace_display_user() as MR_trace_event_internal()
> and MR_trace_debugger_step() as MR_trace_event_external().

MR_query_handler() would be a nice (for MR_trace_debugger_step) name as
it sticks to the naming used in the referenced Mireille article jlp98
(and as it handles the user queries ;-).


More information about the developers mailing list