[m-dev.] Changes to mercury/runtime

Bert Thompson aet at cs.mu.oz.au
Wed Feb 12 14:48:00 AEDT 1997


|Bert wrote:
|> If you have any suggestions on the coding standard or don't want
|> me to hit all the code immediately, speak now or forever hold 
|> your peace. 8^)
|
|I don't think we should export or even use struct, union, or enum tags.
|All structs, unions and enums should be without tag, and should be referred
|to by a typedef'd name. The only exceptions should be structs etc whose
|declarations we have no control over, e.g. struct stat.

I agree. Any differing opinions?

|I think putting _s or _p after variable names to denote static or pointer
|is a bad idea.

I don't think it buys much and most likely people won't stick to it
consistently hence negating its usefulness. Are there other reasons
why you think it's a bad idea? (I'm not putting it into the standard.)

|The indentations on the if statements in 5.1 and 5.2.1 are inconsistent.

I'll fix that up.

It is currently:
        if (this_is_a_somewhat_long_conditional_test(
                in_the_condition_of_an +
                if_then))
        {
                /*...*/
        }

I'll change to:
        if (this_is_a_somewhat_long_conditional_test(
        	        in_the_condition_of_an +
               		if_then)) {
                /*...*/
        }

Personally, I find the K&R-style harder to read, even if it is
more compact.

Bert



More information about the developers mailing list