[m-rev.] diff: s/inst_id/inst_ctor/ s/mode_id/mode_ctor/

Julien Fischer jfischer at opturion.com
Sun Mar 15 14:38:38 AEDT 2020

On Sun, 15 Mar 2020, Zoltan Somogyi wrote:

> Next, I would also like to fix the type
> :- type sym_name_and_arity
>    --->    sym_name_arity(sym_name, arity).
> and its pf_sym_name_and_arity brother. When I work with
> code using this type, I am always tripped up by the fact that
> the type name and the function symbol name differ by the presence
> of the "and_" in the type name. Even when I remember that there is
> this difference, I tend to forget *which* name has the "and_" and
> which doesn't.
> The obvious thing to do is to standardize on either the presence or the
> absence of the "and_". I propose the absence, since that leads to fewer
> long lines that need to be wrapped. Any objections?
> As mentioned in a recent XXX, I would also replace all uses of the old
> simple_call_id with the recent pf_sym_name_and_arity type (or its "and_"-less
> version, depending on the choice above), which is isomorphic to it,
> but whose name does imply that it is specifying something being called.
> Again, are there any objection to this?

No objection to either of the above from me.


More information about the reviews mailing list