[m-rev.] for review: rationalise hash functions across the standard library

Julien Fischer jfischer at opturion.com
Fri Feb 14 20:27:39 AEDT 2020

On Fri, 14 Feb 2020, Zoltan Somogyi wrote:

>>> I would replace ht_cons with something like
>>> ht_more(K, V, K, V, kvlist(K, V)),
>>> where kvlist is defined by
>>> :- type kvlist(K, V)
>>>    --->    kv_nil
>>>    ;    kv_cons(K, V, kv_list(K, V)).
>> I take it this was one motivation for your recent addition of such a
>> type ;-)
> The one and only.
> Tell me when your changes to the hash_table code are done,
> and I will make the change above replacing ht_cons.

You can go ahead; I won't be touching hash_table code for a few
weeks at least.


More information about the reviews mailing list