[m-rev.] diff: disable mfilterjavac by default

Paul Bone paul at bone.id.au
Wed Oct 16 15:58:21 AEDT 2013

On Wed, Oct 16, 2013 at 02:55:58PM +1100, Julien Fischer wrote:
> On Wed, 16 Oct 2013, Paul Bone wrote:
>> Are these really the steps you used to reproduce this problem?  I'm having
>> trouble accepting that they worked at all before I introduced mfilterjavac.
>> I'm also concerned that since it can't find mmc when I have none in my path,
>> that it isn't using the stage1 mmc to build stage2 which is a problem for
>> bootchecking in general.
> I think the problem I had was initially just a bootstrapping problem,
> i.e. rotd-2013-04-18 didn't have mfilterjavac but it was required to
> install from stage2 of rotd-2013-05-01 (suitably modified to remove the
> workaround that disables the use of mfilterjavac).

Okay, thanks.

> Ok, so now that all installations have mfilterjavac the problem should
> go away?  However, why is mmake install (technically install_grades)
> looking at the mfilterjavac in the PATH, not the one it has just built?
> (This is potentially a problem if mfilterjavac itself changes -- however
> unlikely -- in a non backwards compatible manner.)

I agree, this could be an issue.

> Note that for other utility programs, e.g. mfiltercc, mkinit etc, we set
> things up to look at the version in the workspace.  For example from the
> top-level Mmakefile:
>     SUBDIR_MMAKE =  PATH=../scripts:../util:$$PATH \
>                     MMAKE_VPATH=. \
>                     MMAKE_DIR=../scripts \
>                     DESTDIR=$(DESTDIR) \
>                    ../scripts/mmake $(MMAKEFLAGS)
>     SUBSUBDIR_MMAKE = PATH=../../scripts:../../util:$$PATH \
>                     MMAKE_VPATH=. \
>                     MMAKE_DIR=../../scripts \
>                     DESTDIR=$(DESTDIR) \
>                     ../../scripts/mmake $(MMAKEFLAGS)
> For me, the issue here is that you are not using the new mfilterjavac
> (the java grade fails to build for me from stage 2 -- I'm not sure about
> stage 1, but both should work anyway -- when the build compiler lacks
> mfilterjavac, even though the workspace has just built a copy.)
> In short, why do SUBDIR_MMAKE and SUBSUBDIR_MMAKE not also point at
> ../mfilterjavac and ../../mfilterjavac respectively.

The simple reason is "I forgot", so I can fix it and re-test.  What I
propose to test is to chmod 000 my installed mfilterjavac and then try to
run make install from my workspace's stage2 directory.

I never meant to disagree with your description of the path issue.  I just
couldn't reproduce the same result.


Paul Bone

More information about the reviews mailing list