[m-rev.] diff: disable mfilterjavac by default

Julien Fischer jfischer at opturion.com
Wed Oct 16 13:09:29 AEDT 2013

On Wed, Oct 16, 2013 at 1:00 PM, Paul Bone <paul at bone.id.au> wrote:

> On Tue, Oct 15, 2013 at 05:48:50PM +1100, Julien Fischer wrote:
> >
> > All subsequent rotds have disabled mfilterjavac, you will need to
> generate
> > one with it enabled.
> >
> Okay, I can generate an ROTD, but then when I use it, without Mercury in my
> path...
> > (1) Build stage 1 using rotd-2013-04-18
> > (2) Bootcheck (or otherwise build the stage 2 compiler).
> > (3) cd stage2 && mmake install (with the java grade as one of the
> >     grades to install).
> I cannot run the bootcheck script, it expects mmake to be in the path but
> it's not because I don't have a Mercury installation in my path.
> So I commented out an "exit 1" in scripts/bootcheck and tried again.  This
> time it gets as far as building the library, at which point it reports it
> cannot find mmc, even though it used mmc in the previous step (generating
> dependency information).
> So I thought, maybe there's a problem with how buildcheck works and if I
> just run 'make' it will work.  So in stage2 I ran make, and there's no
> Makefile here.  I copied the one from the root of the tree and tried, it
> still can't find mmc.

Are these really the steps you used to reproduce this problem?  I'm having
> trouble accepting that they worked at all before I introduced mfilterjavac.
> I'm also concerned that since it can't find mmc when I have none in my
> path,
> that it isn't using the stage1 mmc to build stage2 which is a problem for
> bootchecking in general.

 Hmm, ok they're clearly not how I originally produced the problem.  I'll
have a look into it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mercurylang.org/archives/reviews/attachments/20131016/2c5eb342/attachment.html>

More information about the reviews mailing list