[m-rev.] OpenGL

Simon Taylor stayl at cs.mu.OZ.AU
Mon Oct 13 16:10:52 AEST 2003

On 13-Oct-2003, Julien Fischer <juliensf at students.cs.mu.OZ.AU> wrote:
> Estimated hours taken: 3
> Branches: main
> Add a little more functionality to the OpenGL binding.  In particular,
> add bindings for vertex fragment operations and (some) support for
> selection.
> Rename the logical_operation type so that the name is more consistent
> with that of other types. e.g. stencil_op, accum_op.
> Change the name of the constructors `notequal' and `noop' to `not_equal'
> and `no_op' respectively.  The new names are clearer than the old ones.

Changes like this which break existing code without a very good
reason should be avoided.

mercury-reviews mailing list
post:  mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe:   Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe

More information about the reviews mailing list