[m-dev.] I want to move and rename the dependency_graph module
paul at bone.id.au
Tue Feb 7 11:59:03 AEDT 2017
On Mon, Feb 06, 2017 at 10:53:44PM +1100, Julien Fischer wrote:
> Hi Paul,
> On Mon, 6 Feb 2017, Paul Bone wrote:
> >compiler/dependency_graph.m has types and routines used to to build and use
> >a dependency graph of the HLDS. I want to add the same for the MLDS. To
> >avoid confusion I want to rename this module hlds.dependency_graph.m so I
> >also have mlds.dependency_graph.m
> In keeping with the names of existing modules that define the HLDS and
> MLDS respectively I would name them hlds_dependency_graph.m and
> >I also plan to extract the common code and probably put it in either
> >dependency_graph.m or libs.dependency_graph.m
> What code will end up in common? Would any of the common code be better
> placed in library/digraph.m?
Some of the types.
Perhaps some of it can go in the library. I'll check this as I go.
> >The current dependency_graph module is part of the transform_hlds module. I
> >would also like to move it to the hlds module. I think it makes more sense
> >there since it's utility code rather than a transformation.
> There is some sense in that as it's imported by other packages in the
> compiler, notably top_level and check_hlds.
That's what I thought. There are a few cases were've I've been able to
remove the dependency on the entire transform_hlds module.
More information about the developers