[m-dev.] Re: Mercury 0.12.0 make fails on SuSE Linux 9.3

Julien Fischer juliensf at cs.mu.OZ.AU
Wed Sep 14 12:26:38 AEST 2005

On Wed, 14 Sep 2005, Ralph Becket wrote:

> Hi Greg,
> J. Greg Davidson, Tuesday, 13 September 2005:
> > I downloaded Mercury 0.12.0 last night and tried to install it.  I got
> > errors on the make stage.  Perhaps this is because SuSE is still using
> > gcc-3.3.5-5?  I've attached my install script to this message.
> What you're seeing is definitely a gcc error; from the 0.12 download
> page there's a section which reads:
> 	 We recommend GCC 3.4.x.
> 	 GCC 3.0, 3.3.1 and 4.0 will NOT work. They have bugs which
> 	 cause internal compiler errors when compiling the C code
> 	 generated by the Mercury compiler.
> 	 Avoid GCC 2.96 (distributed with Red Hat Linux 7.x) and other
> 	 unofficial releases of GCC. Also avoid versions of GCC less
> 	 than GCC 2.95.X.
> Clearly we can add 3.3.5 to the list of buggy gcc compilers :-( We plan
> on adding a test to the configure script in the next few days because
> gcc errors are the number one source of installation problems.

gcc 3.3.5 works perfectly well on a couple of our Debian machines.
The main problem here is that are SuSE installations are getting a bit
long in the tooth (earth is 8.1 and jupiter is something similar.)
(Both of our SuSE machines use gcc 3.2 - although earth actually
boostraps using a hand built version of gcc 3.4.1).

It looks like what is happening on Greg's install is that a gcc
has tried to apply an optimization and run out of registers because
we're using some of them as global register variables.


mercury-developers mailing list
Post messages to:       mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions:          mercury-developers-request at cs.mu.oz.au

More information about the developers mailing list