diff: reference_manual.texi: module qualifiers

Fergus Henderson fjh at cs.mu.oz.au
Mon Jul 28 20:34:50 AEST 1997


doc/reference_manual.texi:
	Improve the documentation of module qualifiers:
	document (and recommend the use of) `__' as an alternative to `:'.

Index: reference_manual.texi
===================================================================
RCS file: /home/staff/zs/imp/mercury/doc/reference_manual.texi,v
retrieving revision 1.61
diff -u -r1.61 reference_manual.texi
--- reference_manual.texi	1997/07/27 15:05:44	1.61
+++ reference_manual.texi	1997/07/28 10:33:15
@@ -2295,11 +2295,18 @@
 @code{import_module} or @code{use_module} declaration should be in 
 the implementation section.
 
-Declarations, predicate calls, types, modes and insts
-can be explicitly module qualified using the `:' operator,
-i.e. @code{module:name}.  This is useful both for readability and
+The names of predicates, functions, constructors, types, modes and insts
+can be explicitly module qualified using the @samp{:} operator,
+i.e. @samp{module:name}.  This is useful both for readability and
 for resolving name conflicts.  Uses of entities imported using 
 @code{use_module} declarations @emph{must} be explicitly module qualified.
+
+Currently we also support @samp{__} as an alternative module qualifier,
+so you can write @code{module__name} instead of @code{module:name}.
+We are considering changing the module qualifier from @samp{:}
+to @samp{.} in a future version, so that we can use @samp{:} as
+a type qualifier instead.  Hence for the time being we recommend
+that you use @samp{__} rather than @samp{:} as module qualifier.
 
 Certain optimizations require information or source code for predicates
 defined in other modules to be as effective as possible.  At the moment,
-- 
Fergus Henderson <fjh at cs.mu.oz.au>   |  "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh>   |  of excellence is a lethal habit"
PGP: finger fjh at 128.250.37.3         |     -- the last words of T. S. Garp.



More information about the developers mailing list