[mercury-users] Re: Facilities of Nercury

Lee Naish lee at cs.mu.oz.au
Thu Mar 6 11:11:44 AEDT 1997

In message <199703052254.IAA03445 at ballet.dstc.gu.edu.au>you write:
>> and (tentatively) expand/4 (`=..' is hardly mnemonic, and expand/4 is
>> not much better; does anyone have a suggestion for a better name for
>> this predicate?).
>explode/4, dismember/4, disassemble/4 ?
>but it would be nice to have a name that works for both
>forward and backward modes.  Perhaps reflect/4 ?

components, parts, functor_args, args, mvu (Mercury version of univ),...

BTW, what are the four arguments (I can probably guess, but...)?


More information about the users mailing list