Make polymorphism_goal.m more readable. Add Caller and Callee prefixes to variable names as appropriate to explicitly disambiguate them. Make a single predicate responsible for processing plain_calls. Make a single predicate responsible for processing foreign proc calls. Rename the predicate that helps with both.