Make two calendar tests easier to check ...

... by making the output easier to read.

tests/hard_coded/calendar_date_time_conv.m:
tests/hard_coded/calendar_duration_conv.m:
    These test cases test date_time_from_string and duration_from_string
    functionality respectively. Both test cases test both

    - the semidet predicate version and
    - the det function version

    of their respective operations.

    Change these test cases so that the predicate and function versions
    are not tested separately. Instead, test the predicate version,
    and then generate an output for the function version ONLY if its result
    differs from the result of the predicate version.

    Change the format of the output, from a single very long line for each
    test input, to a short paragraph for each input. Line up related text
    (such as a test string and its roundtripped version) with vertical
    alignment to make any differences easier to see.

tests/hard_coded/calendar_date_time_conv.exp:
tests/hard_coded/calendar_duration_conv.exp:
    Expect the updated output.
