[m-rev.] [m-users.] Debugger, setting initial breakpoint not triggering
Zoltan Somogyi
zoltan.somogyi at runbox.com
Tue Dec 20 01:00:54 AEDT 2022
On Tue, 20 Dec 2022 00:30:59 +1100 (AEDT), Julien Fischer <jfischer at opturion.com> wrote:
> > The attached diff does this. Does anyone have an opinion on
> > renaming the .ll_debug grade component, and on whether
> > it can be done without temporary backwards compatibility?
> > I think it can be done, but I am open to being persuaded otherwise.
>
> There's no need to preserve backward compatibility in this case.
> (The .ll_debug grades are not part of a standard install.)
That was my position as well.
> > +AC_ARG_ENABLE(hlc-gdb-grades,
> > + AS_HELP_STRING([--enable-hlc-gdb-grades],
> > + [install a gdb-debuggable version of the high level C grade]),
> > + [enable_hlc_gdb_grades="$enableval"],[enable_hlc_gdb_grades=no])
>
> Putting gdb in there suggests you have to use gdb. I have certainly
> debugged Mercury generated C compiled with clang using lldb in the past.
> That said, I can't think of a better name for the option and the new one
> will at least prevent confusion.
I kept the option name as hlc-gdb-grades, but replaced the help message with
install a version of the high level C grade to supports debuggers for C
This is just short enough to fit on one line.
> > -if test "$enable_hlc_ll_debug_grades" = yes; then
> > +# Add grades that support debugging using gdb.
> > +if test "$enable_hlc_gdb_grades" = yes; then
> > + # XXX We should rename the ".ll_debug" grade component,
> > + # possibly to ".gdb_debug". We could add this is a synonym at first,
> > + # and then stop accepting ".ll_debug", but we could just straight up
> > + # do a non-bootstrapped replacement.
> > LIBGRADES="$LIBGRADES hlc.gcd.ll_debug"
>
> Could we just do .ll_debug -> .c_debug? Or is the latter still to close
> the names of the Mercury debugging grade components?
We could, and I will do that now as a separate change.
Zoltan.
More information about the reviews
mailing list