[m-rev.] for post-commit review: more inst_match.m cleanups

Peter Wang novalazy at gmail.com
Fri Feb 26 10:57:36 AEDT 2021

On Thu, 25 Feb 2021 12:23:09 +1100 "Zoltan Somogyi" <zoltan.somogyi at runbox.com> wrote:
> For review by anyone.
> Zoltan.

> Clean up more modechecking code.
> compiler/inst_match.m:
>     Change the predicates that compare two insts to make the nested switch
>     (first on one inst, then the other), make the nesting explicit.
>     Give a predicate a more meaningful name.
>     Add XXXs on dodgy code.

That's fine.


More information about the reviews mailing list