[m-rev.] for post-commit review: var_name_print and output_lang

Julien Fischer jfischer at opturion.com
Wed Apr 8 17:07:59 AEST 2020

On Wed, 8 Apr 2020, Zoltan Somogyi wrote:

> This diff is stage 1 of implementing the first approach by making it
> possible to update the names of variables holding compiler-generated
> type_infos in foreign_procs to a new naming scheme in which names
> such as TypeInfo_for_<typevarname> are replaced with names such as
> TypeInfo_{In,Out}_<seqnum>. Once this diff is installed, I will update
> the foreign_procs (stage 2), and once *that* is all done, I will replace
> this workaround (stage 3).
> This diff has passed bootcheck in hlc.gc and asm_fast.gc. I am bootchecking
> it in grade java now; it has just started the tests. An earlier version has
> bootchecked in the csharp grade with 69 unexpected failures, which is
> par for the course (in other words, they are actually expected :-);
> I will repeat the bootcheck with the current version before commit.
> And of course I have visually checked the generated code for small
> test cases both for the usual case of input type_infos, and for code like
> type_desc.has_type, in which the type_info is output. I have also
> checked that the compiler will do the right thing on that small
> test case even after the foreign_proc switches to using the new
> naming scheme, though a full test of that functionality is not
> possible before this diff has been installed.
> Julien, could I ask you to review this?

Done, the diff looks fine.


More information about the reviews mailing list