[m-rev.] for review: diffs for arg type lists
zoltan.somogyi at runbox.com
Wed Jan 2 21:16:45 AEDT 2019
On Sun, 30 Dec 2018 02:49:55 +0000 (UTC), Julien Fischer <jfischer at opturion.com> wrote:
> > library/diff.m:
> > A new module for computing diffs.
> One small issue here is that the in samples/diff we have a module named diff.
> That should probably be renamed.
Since that sample is a whole program, like the original diff, and my new module
isn't, I think it preferable to rename my new module instead. Does "edit_seq"
meet with people's approval?
> This test should be more comprehensive, for example if the declaration or
> clause has arity 0, if there is more than one difference between the lists,
> where the declaration involved is a function etc.
> > diff --git a/tests/invalid/try_detism.err_exp b/tests/invalid/try_detism.err_exp
> > index 90d2822..5bd877b 100644
> > --- a/tests/invalid/try_detism.err_exp
> > +++ b/tests/invalid/try_detism.err_exp
> This one has changed more than I would have expected; is it just that its not
> often run -- there is a .err_exp2 file for this one as well -- or is there some
> other reason for the differences?
You are right, I updated the .err_exp file when I should have updated the .err_exp2 file.
More information about the reviews