[m-rev.] for review: make each SCC a set

Zoltan Somogyi zoltan.somogyi at runbox.com
Fri Feb 17 13:22:02 AEDT 2017

For review by anyone.

I think digraph.m should have predicates that returns the list of SCCs
in the graph in BOTH orders, not just one, and I think that the names
of those predicates should say what the order they return is. The current
atsort predicate can be a synonym for one of these.

Names like return_bottom_up_sccs and return_top_down_sccs would work
only if for each edge x->y, it were obvious which of x and y is higher.
For our use case, this is clear, but for other use cases, it could be clear
the other way around. Any ideas for better names? All I came up with
are return_sccs_in_from_to_order and return_sccs_in_to_from_order,
relying on the fact that it is pretty clear that x is "from" and y is "to",
but those names are not exactly catchy.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Log.dep
Type: application/octet-stream
Size: 2381 bytes
Desc: not available
URL: <http://lists.mercurylang.org/archives/reviews/attachments/20170217/299539ae/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: DIFF.dep
Type: application/octet-stream
Size: 139636 bytes
Desc: not available
URL: <http://lists.mercurylang.org/archives/reviews/attachments/20170217/299539ae/attachment-0003.obj>

More information about the reviews mailing list