[m-rev.] for review: Add maybe.semidet_to_maybe
jfischer at opturion.com
Wed Aug 10 16:12:19 AEST 2016
On Wed, 10 Aug 2016, Paul Bone wrote:
> For review by anyone
> After adding this function and preparing the commit I found that there are
> some similar, but probably different enough predicates and functions in
> std_util.m Maybe they should be moved to maybe?
> Please also consider the name.
I suggest "pred_to_maybe", since we name the similar function in the bool
The rest of the diff is fine.
More information about the reviews