[m-rev.] for review: priority search queue ADT

Julien Fischer jfischer at opturion.com
Thu Nov 27 14:42:36 AEDT 2014

Hi Paul

On Thu, 27 Nov 2014, Paul Bone wrote:

> I've adding this to Mercury at the moment.  Do you have some test code that
> I can commit to the test suite?
> I'm very sorry for making this drag on.  I'll commit the code now and fix up
> the few minor issues with a commit of my own.

If you're going to look at this then I won't bother a review of it
before it's committed.  A few things though:

- the singleton/2 function should be exported.
- the 'del_min' operation should named 'remove'.
- the 'lookup' operation should be named 'search'.
- the 'det_lookup' option should be named 'lookup'

The above renaming are more consistent with the names in the
map module etc.


More information about the reviews mailing list