[m-rev.] diff: workaround to fix nightly builds
Ralph Becket
rafe at cs.mu.OZ.AU
Tue Aug 16 11:08:03 AEST 2005
Mark Brown, Monday, 15 August 2005:
> Index: library/map.m
> ===================================================================
> RCS file: /home/mercury1/repository/mercury/library/map.m,v
> retrieving revision 1.98
> diff -u -r1.98 map.m
> --- library/map.m 16 Jun 2005 04:08:02 -0000 1.98
> +++ library/map.m 15 Aug 2005 09:13:39 -0000
> @@ -442,6 +442,24 @@
> :- func 'map__det_elem :='(K, map(K, V), V) = map(K, V).
>
> %-----------------------------------------------------------------------------%
> +
> + % A "renaming" is a map where the keys and values have the
> + % same type.
> + %
> +:- type renaming(T) == map(T, T).
> +
> + % Follow a chain of renamed elements until we find one that is
> + % not renamed.
> + %
> +:- func map__search_transitively(renaming(T), T) = T.
> +:- pred map__search_transitively(renaming(T)::in, T::in, T::out) is det.
I think `map__renaming' is a better name for this func/pred. But I'm
not that upset by map__search_transitively if that's what you prefer.
Otherwise that looks fine to me.
-- Ralph
--------------------------------------------------------------------------
mercury-reviews mailing list
post: mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------
More information about the reviews
mailing list