[m-rev.] diff: pragma_type field names

Fergus Henderson fjh at cs.mu.OZ.AU
Wed Nov 5 14:48:39 AEDT 2003


On 05-Nov-2003, Zoltan Somogyi <zs at cs.mu.OZ.AU> wrote:
> compiler/prog_data.m:
> 	Add field names to the pragma_type type.
...
> +	;	export(
> +			exp_predname	:: sym_name,
> +			exp_p_or_f	:: pred_or_func,
> +			exp_modes	:: list(mode),
> +			exp_c_func	:: string
>  			% Predname, Predicate/function, Modes,
>  			% C function name.

Instead of "exc_c_func", I suggest "exp_foreign_name" or "exp_exported_name".

> +	;	unused_args(
> +			unused_p_or_f	:: pred_or_func,
> +			unusused_name	:: sym_name,

s/unusused_name/unused_name/

> +			unused_arity	:: arity,
> +			unused_mode	:: mode_num,
> +			unused_args	:: list(int)
>  			% PredName, Arity, Mode number, Optimized pred name,
>  			% 	Removed arguments.

The comment about "Optimized pred name" seems to be wrong
and should probably be deleted.

> -	;	fact_table(sym_name, arity, string)
> +	;	fact_table(
> +			facttable_name	:: sym_name,
> +			facttable_arity :: arity,
> +			facttable_file	:: string
>  			% Predname, Arity, Fact file name.

Please s/facttable/fact_table/g

-- 
Fergus Henderson <fjh at cs.mu.oz.au>  |  "I have always known that the pursuit
The University of Melbourne         |  of excellence is a lethal habit"
WWW: <http://www.cs.mu.oz.au/~fjh>  |     -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-reviews mailing list
post:  mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe:   Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------



More information about the reviews mailing list