[m-rev.] for review: list__sort_and_remove_equivs/3
Fergus Henderson
fjh at cs.mu.OZ.AU
Fri Sep 6 14:16:34 AEST 2002
On 06-Sep-2002, Ralph Becket <rafe at cs.mu.OZ.AU> wrote:
> Mark Brown, Friday, 6 September 2002:
> > On 05-Sep-2002, Fergus Henderson <fjh at cs.mu.OZ.AU> wrote:
> > > On 05-Sep-2002, Mark Brown <dougl at cs.mu.OZ.AU> wrote:
> > > The same issue arises with list__merge_and_remove_dups,
> > > so you might want to define list__merge_and_remove_equivs too.
> > >
> [...]
> > >
> > > The documentation here is not very precise/clear.
> >
> > I agree. Unfortunately, I was merely mimicking the documentation for
> > list__sort_and_remove_dups which has the same problem. Likewise with
> > the code. I'll fix both the old and the new stuff.
>
> Overloading list__sort_and_remove_dups etc. seems a better name for the
> version that takes a comparison predicate argument, anyway.
We already do that. Mark is talking about adding a third variant.
func list__sort_and_remove_dups/1:
sort using the builtin comparison,
detect duplicates using the builtin equality
func list__sort_and_remove_dups/2:
sort using the supplied comparison,
detect duplicates using the builtin equality
func list__sort_and_remove_equivs/2:
sort using the supplied comparison,
detect duplicates using the supplied comparison
--
Fergus Henderson <fjh at cs.mu.oz.au> | "I have always known that the pursuit
The University of Melbourne | of excellence is a lethal habit"
WWW: <http://www.cs.mu.oz.au/~fjh> | -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-reviews mailing list
post: mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------
More information about the reviews
mailing list