[m-rev.] for review: dependency tracking
Zoltan Somogyi
zs at cs.mu.OZ.AU
Tue Apr 23 11:40:22 AEST 2002
On 22-Apr-2002, Mark Brown <dougl at cs.mu.OZ.AU> wrote:
> > +:- func head_vars_presentation = which_headvars.
>
> A better name for this function would be default_head_vars_presentation.
No, it wouldn't, since there is no way to override this "default". I changed
the name to chosen_head_vars_presentation; do you have a better suggestion?
> Now that it is possible to get to the (parent) goal path of interface
> events, I think it would be worth doing this for all the interface events
> here. You don't need to as part of this change, since it wouldn't be used
> anyway. But it does make more sense than returning the empty string as
> currently happens.
OK, I added a XXX.
> > + { Command = browse(ArgNum) },
> > + browse_edt_node(Node, ArgNum, MaybeMark, User1, User2),
> > (
> > { MaybeMark = no },
> > query_user_2([Node | Nodes], Skipped, Response, User2,
> > User)
> > ;
> > { MaybeMark = yes(Mark) },
> > - { Answer = suspicious_subterm(Node, Arg, Mark) },
> > + { Which = head_vars_presentation },
> > + {
> > + Which = only_user_headvars,
> > + ArgPos = user_head_var(ArgNum)
> > + ;
> > + Which = all_headvars,
> > + ArgPos = any_head_var(ArgNum)
> > + },
> > + { Answer = suspicious_subterm(Node, ArgPos, Mark) },
> > { Response = user_answer(Answer) },
> > { User = User2 }
> > )
>
> A suggestion on naming: perhaps you could use UserArgPos and RealArgPos
> to distinguish the two ways of numbering arguments.
I agree that it should be possible to find better variable names, but I don't
like RealArgPos. This code doesn't convert from one kind of argument number to
the other; it merely records what kind of argument number the browser returned,
to allow other code to do the conversion.
Zoltan.
--------------------------------------------------------------------------
mercury-reviews mailing list
post: mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------
More information about the reviews
mailing list