[m-rev.] diff: improve mmake support for high level data on IL backend

Fergus Henderson fjh at cs.mu.OZ.AU
Mon Jul 23 19:06:20 AEST 2001


On 18-Jul-2001, Peter Ross <peter.ross at miscrit.be> wrote:
> Index: compiler/modules.m
...
> +write_dll_dependencies_list(Modules0, DepStream) -->
> +	{ F = (func(M) =
> +		( if M = unqualified(S), mercury_std_library_module(S) then
> +			unqualified("mercury")
> +		else
> +			M
> +		)
> +	)},
> +	{ Modules = list__remove_dups(list__map(F, Modules0)) },
> +	list__foldl(write_dll_dependency(DepStream), Modules).

It would help to use more meaningful names here.  I think it would be
clearer if the function `F' was written as a separate function, named say
"module_dll_name", rather than as a lambda expression.

-- 
Fergus Henderson <fjh at cs.mu.oz.au>  |  "I have always known that the pursuit
The University of Melbourne         |  of excellence is a lethal habit"
WWW: <http://www.cs.mu.oz.au/~fjh>  |     -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-reviews mailing list
post:  mercury-reviews at cs.mu.oz.au
administrative address: owner-mercury-reviews at cs.mu.oz.au
unsubscribe: Address: mercury-reviews-request at cs.mu.oz.au Message: unsubscribe
subscribe:   Address: mercury-reviews-request at cs.mu.oz.au Message: subscribe
--------------------------------------------------------------------------



More information about the reviews mailing list