[m-dev.] question about mode representation
zoltan.somogyi at runbox.com
Sun Apr 1 12:40:32 AEST 2018
On Sun, 1 Apr 2018 11:11:38 +1000, Peter Wang <novalazy at gmail.com> wrote:
> > I have two questions for everyone.
> > The first is: what should this new goal_info field, and its type, be called?
> var_modes? var_inst_deltas?
It can't be var_inst_deltas, since the new field won't contains either insts
or inst deltas.
var_modes is better, but the field describes the mode of a goal. In one
special case (a call to a predicate such as error which cannot return)
it won't contain variable-specific information at all; it will just say
that the program point after the goal is unreachable.
> goal_mode(s) sounds acceptable.
That is the one I prefer so far.
More information about the developers