[m-dev.] tightening up require_complete_switch
novalazy at gmail.com
Tue Apr 19 17:41:30 AEST 2016
On Tue, 19 Apr 2016 17:27:16 +1000 (AEST), "Zoltan Somogyi" <zoltan.somogyi at runbox.com> wrote:
> On Tue, 19 Apr 2016 14:05:32 +1000, Peter Wang <novalazy at gmail.com> wrote:
> > > Why? Don't you find the variable useful documentation? There are some
> > > disjunctions that can be looked at as switches on *more* than one variable
> > > (e.g. assoc_list.from_corresponding_lists); I find the variable name slightly
> > > useful in that it tells me "you don't have to search for another variable
> > > that this disjunction is a switch on".
> > Perhaps, only just useful.
> Does this, ...
> > > We could in future even use the
> > > variable name in the scope to control switch detection, by checking
> > > whether the disjunction it is given is a switch on the named variable
> > > *before* checking to see if it is a switch on any other variables.
> > > (In fact, I think this should be easy to implement.)
> > True.
> ... and this mean that you don't object to keeping the [Var] part?
Yes, it's only a minor thing.
More information about the developers