[m-dev.] for discussion: pragma foreign_import
Fergus Henderson
fjh at cs.mu.OZ.AU
Thu Dec 6 13:56:23 AEDT 2001
Apart from the naming issue that Simon raised, this looks fine to me.
I have a few minor suggestions below.
On 05-Dec-2001, Peter Ross <peter.ross at miscrit.be> wrote:
> + at subsubsection pragma foreign_import for C
> +
> +To import a C function on the C backend
> +use @code{c} for @var{Lang},
I suggest s/@code/@samp/
> + at subsubsection pragma foreign_import for IL
> +
> +To import an IL function on the IL backend
> +use @code{il} for @var{Lang},
Likewise here.
> +and @var{Name} is the IL syntax for class method references.
> +
> +For example, the following code imports the IL function @samp{Cos()}
I suggest s/the IL function/the IL static member function/
and s/Cos()/System.Math.Cos()/
--
Fergus Henderson <fjh at cs.mu.oz.au> | "I have always known that the pursuit
The University of Melbourne | of excellence is a lethal habit"
WWW: <http://www.cs.mu.oz.au/~fjh> | -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-developers mailing list
Post messages to: mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions: mercury-developers-request at cs.mu.oz.au
--------------------------------------------------------------------------
More information about the developers
mailing list