[m-dev.] for review: bootstrap hlc.gc.memprof grade
Fergus Henderson
fjh at cs.mu.OZ.AU
Wed Aug 2 12:08:46 AEST 2000
On 01-Aug-2000, Peter Ross <peter.ross at miscrit.be> wrote:
> Here is the relative diff.
> +++ compiler/mlds_to_c.m Tue Aug 1 18:17:53 2000
> @@ -315,16 +314,61 @@
> %-----------------------------------------------------------------------------%
>
> %
> - % Output the function `mercury__<modulename>_init()'.
> + % Maybe output the function `mercury__<modulename>_init()'.
> % The body of the function consists of calls
> % init_entry(<function>) for each function defined in the
> % module.
s/init_entry/MR_init_entry/
> @@ -1917,21 +1944,15 @@
> % is e.g. inside an if-then-else.
> %
> mlds_indent(Indent),
> | io__write_string("{\n"),
>
> | mlds_maybe_output_call_profile_instr(Context,
> | Indent+1, FuncRval, Name),
s/+1/ + 1/
> @@ -1956,12 +1977,12 @@
>
> ( { IsTailCall = tail_call, Results = [] } ->
> mlds_indent(Context, Indent + 1),
> + io__write_string("return;\n")
> ;
> []
> + ),
> + mlds_indent(Indent),
> + io__write_string("}\n")
I think that should be
mlds_indent(Context, Indent)
rather than
mlds_indent(Indent)
so that you get the right `#line' directives.
> @@ -2225,22 +2303,10 @@
> + { FuncInfo = func_info(FuncName, _) },
> + mlds_maybe_output_heap_profile_instr(Context, Indent+1, Args, FuncName,
> + MaybeCtorName),
s/+1/ + 1/
Otherwise that looks fine.
--
Fergus Henderson <fjh at cs.mu.oz.au> | "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh> | of excellence is a lethal habit"
PGP: finger fjh at 128.250.37.3 | -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-developers mailing list
Post messages to: mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions: mercury-developers-request at cs.mu.oz.au
--------------------------------------------------------------------------
More information about the developers
mailing list