[m-dev.] for review: use MR_CHECK_EXPR_TYPE() macro

Fergus Henderson fjh at cs.mu.OZ.AU
Mon Apr 3 16:35:37 AEST 2000


On 27-Mar-2000, Fergus Henderson <fjh at cs.mu.OZ.AU> wrote:
> Improve the static type checking and readability of
> some of the macros that we define, by using a new
> MR_CHECK_EXPR_TYPE() macro.

I'll go ahead and commit that.

Merging that with changes committed since I posted it
required also making the following change:

runtime/mercury_type_info.c:
	Ensure that the parameter that we pass to
	MR_TYPE_VARIABLE_IS_UNIV_QUANT() has type
	`MR_PseudoTypeInfo', rather than `Unsigned'.

Index: /home/pgrad/fjh/ws/alpha/runtime/mercury_type_info.c
===================================================================
RCS file: /home/mercury1/repository/mercury/runtime/mercury_type_info.c,v
retrieving revision 1.34
diff -u -d -u -r1.34 mercury_type_info.c
--- /home/pgrad/fjh/ws/alpha/runtime/mercury_type_info.c	2000/03/24 10:27:51	1.34
+++ /home/pgrad/fjh/ws/alpha/runtime/mercury_type_info.c	2000/04/02 06:27:24
@@ -79,7 +79,7 @@
 
 	arg_num = (Unsigned) pseudo_type_info;
 
-	if (MR_TYPE_VARIABLE_IS_UNIV_QUANT(arg_num)) {
+	if (MR_TYPE_VARIABLE_IS_UNIV_QUANT(pseudo_type_info)) {
 		/*
 		** This is a universally quantified type variable.
 		*/

-- 
Fergus Henderson <fjh at cs.mu.oz.au>  |  "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh>  |  of excellence is a lethal habit"
PGP: finger fjh at 128.250.37.3        |     -- the last words of T. S. Garp.
--------------------------------------------------------------------------
mercury-developers mailing list
Post messages to:       mercury-developers at cs.mu.oz.au
Administrative Queries: owner-mercury-developers at cs.mu.oz.au
Subscriptions:          mercury-developers-request at cs.mu.oz.au
--------------------------------------------------------------------------



More information about the developers mailing list