diff/for review: changes to runtime

Fergus Henderson fjh at cs.mu.OZ.AU
Mon Jun 15 16:57:19 AEST 1998


Hi,

Tom, can you please review these changes?

I'll commit them now anyway, since the version currently
checked in doesn't compile in some grades.

--------------------

Various minor cleanups to fix some things introduced in recent
changes to the runtime.

mercury_context.c:
mercury_context.h:
mercury_regorder.h:
mercury_regs.h:
mercury_thread.c:
mercury_thread.h:
mercury_type_info.c:
mercury_engine.h:
mercury_engine.c:
	Fix up the layout in a few places.  For multi-line macros
	defined using `do { ... } while (0)', put the `do {' on a line
	of its own.
	Change some names to conform to our standard naming
	convention and to avoid name clashes:
		s/Context/MR_Context/g
		s/CONTEXT/MR_context_struct/g
		s/SYNCTERM/MR_sync_term/g
		s/sp/MR_sp/g
		s/curfr/MR_curfr/g
		s/maxfr/MR_maxfr/g

mercury_engine.h:
mercury_engine.c:
	Fix a couple of bugs that caused it to not compile in certain
	grades.
	Delete some obsolete comments.  Add some new ones and rearrange
	some of the code to make it more readable.

mercury_type_info.c:
	Cast values used in switch statements to (int), to avoid
	a warning from gcc.

-- 
Fergus Henderson <fjh at cs.mu.oz.au>  |  "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh>  |  of excellence is a lethal habit"
PGP: finger fjh at 128.250.37.3        |     -- the last words of T. S. Garp.



More information about the developers mailing list