[m-dev.] for review: new debugger command set, part 1

Peter Schachte pets at students.cs.mu.OZ.AU
Wed Jul 8 10:27:12 AEST 1998

On Tue, 7 Jul 1998, Fergus Henderson wrote:
> On 07-Jul-1998, Zoltan Somogyi <zs at cs.mu.OZ.AU> wrote:
> > > > restart
> > > I'm not sure this is a good name for this command.
> > I am not sure what would be a better name (redo and retry are also bad).
> > How about "again"? Any other suggestions?
> Looking at the alternatives, maybe restart isn't so bad after all.

`restart' sounds like you're starting the whole computation over, from the
start. `again' sounds to me more like you're repeating your last debugger
action than that you're trying a single goal again.

What's the matter with `retry'?  It sounds like you want to try the goal
again, which is what you want to do.  I agree `REDO' is not a very
descriptive name for the debugger port (maybe 'ALT' would have been better),
but `retry' seems to me a fine name for the command. 

-Peter Schachte               | ....I have not failed. I've just found
mailto:pets at cs.mu.OZ.AU       | 10,000 ways that won't work.
http://www.cs.mu.oz.au/~pets/ |     -- Thomas Edison 
PGP: finger pets at | 

More information about the developers mailing list