[m-dev.] Reorganization of mercury_memory.c

Andrew Bromage bromage at cs.mu.OZ.AU
Tue Apr 28 10:19:50 AEST 1998

G'day all.

On 27-Apr-1998, Tyson Dowd <trd at cs.mu.OZ.AU> wrote:

> > > 	mercury_memory.{c,h}
> > > 		The leftovers.

On 27-Apr-1998, Fergus Henderson <fjh at cs.mu.OZ.AU> wrote:

> > What's in the leftovers?

Tyson Dowd wrote:

> Mostly, and some debugging code, and a few thinks like checked_malloc.

The "de facto" Mercury module naming scheme tends to name modules like
this as mercury_memory_util.{c,h}.  Just a suggestion.

Andrew Bromage

More information about the developers mailing list