[m-dev.] debugger naming (was: a big step towards the trace-based debugger)

Andrew Bromage bromage at cs.mu.OZ.AU
Fri Apr 3 11:33:20 AEST 1998

G'day all.

Fergus Henderson wrote:

> We need names for the following debuggers:

I must remind all present of the well-established rules for naming
software.  The possibilities are:

	- Pick the acronym first, then choose the name to fit that.
	  At the moment, the best choice seems to be "MERcury
	  Debugger", or merd for short.  Our French colleagues I'm
	  sure will concur that this is indeed a sufficiently
	  humorous acronym.

	- The Unix solution, which is to (a) arbitrarily cut off
	  the name at three letters, (b) remove all vowels, or
	  (c) both.  "mrcrydbggr" is a bit long, but "mrcdb" may
	  well work here as a compromise, provided the filename
	  contains enough patch information, for example:

	- The completely obscure difficult-to-associate-with-us
	  name.  Unfortunately, "Opium" has already been taken, but
	  my suggestion would be something like "Ludolph" or perhaps
	  "Pavanne".  This will leave users suitably puzzled as to
	  what the point of the exercise really was.

	- Name it after a famous researcher in the field or, even
	  better, some dead person in an ancestor field who probably
	  wouldn't have agreed with the research at all.  All the
	  more famous ones like "Goedel", "Turing" and "Haskell" are
	  unfortunately taken (sadly, "Craig" doesn't quite have the
	  same ring to it, nor does "van Heijenoort"), so I suggest
	  "Girard", "Herbrand" or "Peano".

	- The run-together illegally-capitalised trendy corporate
	  name.  I suggest "LogiFix".

> I suggest that we provide a front-end script called `mdb' which,
> with appropriate options, will invoke any one of these.
> The default would be whichever one happens to be best -- currently (a).
> And since (b) and (c) are not yet implemented, `mdb' would currently
> just be a trivial front-end to (a).

At the moment, mdb.m is the name of the debugger front-end in
mercury/bytecode.  I suggest, Bert, renaming this as mercury_debug.m
(in line with mercury_compile, mercury_profile etc).

Andrew Bromage

More information about the developers mailing list