[m-dev.] for review: runtime changes

Fergus Henderson fjh at cs.mu.oz.au
Mon Nov 10 15:25:05 AEDT 1997


Thomas Charles CONWAY, you wrote:
> This diff starts migrating global variables into virtual registers,
> removes some junk code to do with parallelism, and renames the
> special registers with mr_ prefixes.

Please s/mr_/MR_/g

> +	if (free_context_list == NULL) {
> +		c = (Context *) malloc(sizeof(Context));
> +		assert(c);

That's not the right way to allocate memory.
Probably you should use the make() macro, which calls newmem().

		c = make(Context);

> -do_runnext:
...
> -do_schedule:
...
> -do_join_and_terminate:
...

Won't these still be needed?

-- 
Fergus Henderson <fjh at cs.mu.oz.au>   |  "I have always known that the pursuit
WWW: <http://www.cs.mu.oz.au/~fjh>   |  of excellence is a lethal habit"
PGP: finger fjh at 128.250.37.3         |     -- the last words of T. S. Garp.



More information about the developers mailing list