[m-dev.] cleanup of runtime/*

Bert Thompson aet at cs.mu.oz.au
Mon Feb 10 12:45:37 AEDT 1997


|Hi,
|
|Bert, can you please review the following change?

Fergus,

I've just reviewed it. It looks ok and agrees with the log message.
Note that I haven't gone through it with a fine-tooth comb since
I assume:
	a) You've compiled it and done at least minimal tests.
	b) You have not deliberately introduced errors to test
	   my reviewing.

Here are my suggestions:

- Using #include <...> rather than #include "..." is preferable since
  it means the directory hierarchies can be rearranged without to
  much pain. (This is general point and not relevant to your changes.)

- There are a few typos and spellos of no consequence, such as `delted'
  rather than `deleted' and `schitzophrenic' rather than `schizophrenic'.

- The `#ifdef PARALLEL' stuff should have an `XXX' in the comments
  since the definition and declaration of num_procs etc. must both
  be either #ifdef'ed in or #ifdef'ed out. It might be easy to get
  them out of synch. Also, as you mention in comments, this would
  better be done using a compiler switch. Unnecessary use of #ifdefs
  makes code hard to read and maintain.

- I don't understand why you've nuked `new_context' and `delete_context'
  from context.mod. (Maybe I missed something, but just in case...)

- There's 4-space indenting in deep_copy.c. Inconsistent. Maybe it's
  justified. (This is not relevant to your diff, but just a general
  observation.)

- Vast masses removed from imp.h. It's not obvious to me where it went.
  Was it dead code?

- The comments #ifndef are not standardised. Some use #endif /* ! BLAH */.
  Others use #endif /* not BLAH */. 

- Should add typedefs for ulong, uchar, ushort, uint to std.h since 
  they are well-established C idioms.

- Curlies have been removed from case 's' and case 'z' in wrapper.mod.
  It's not clear to me why this was done.


Don't bother giving any detailed response to this. Make any changes
you think are appropriate. If there's anything I might want to change
when I hit the C runtime code, tell me.

Bert




More information about the developers mailing list